兼容所有浏览器的阻止事件冒泡封装

2017-4-12 17:09| 作者: admin| 查看: 1486| 评论: 0|来自: 蚂蚁部落

由于当前很多时候还需要低版本的IE浏览器,所以在阻止事件冒泡的时候也需要兼容。

下面就分享一个能够兼容所有浏览器的阻止事件冒泡功能封装。

代码如下:

[JavaScript] 纯文本查看 复制代码
function stopBubble(e){
  if(e && e.stopPropagation){
    e.stopPropagation();
  }
  else{
    window.event.cancelBubble=true;
  }
  return false;
}

鲜花

握手

雷人

路过

鸡蛋

最新评论

返回顶部